Workflow-Benutzeroberfläche
Workflows in GOAT bieten ein mächtiges visuelles Automatisierungssystem zur Erstellung anspruchsvoller räumlicher Analysepipelines. Anstatt einzelne Werkzeuge nacheinander auszuführen, können Sie mehrere Analyseschritte mit einer Drag-and-Drop-Leinwand verbinden und dabei eine automatisierte Datenverarbeitung erstellen, die wiederholende manuelle Arbeit eliminiert.
Die Workflows können bei verschiedenen Datensätzen und Szenarien wiederverwendet werden. Jeder Workflow besteht aus verschiedenen Arten von Knoten, die durch Kanten verbunden sind, und ermöglicht Ihnen:
- Automatisierung komplexer analytischer Pipelines: Verketten Sie mehrere Werkzeuge, bei denen die Ausgabe einer Analyse automatisch in die nächste eingespeist wird
- Erstellen von Multi-Source-Daten-Workflows: Bauen Sie anspruchsvolle Analyseprozesse auf, die mehrere Datensätze und Verarbeitungsschritte integrieren
- Dokumentieren automatisierter Prozesse: Fügen Sie Textanmerkungen hinzu, um Methodik und analytische Entscheidungen zu erklären
- Ausführung mit flexibler Automatisierung: Führen Sie einzelne Knoten aus, führen Sie Workflow-Segmente aus oder automatisieren Sie ganze Pipelines
- Erstellen wiederverwendbarer Automatisierungsvorlagen: Speichern Sie Workflows innerhalb von Projekten für die Wiederholbarkeit bei verschiedenen Szenarien
- Nutzen erweiterter Automatisierungsfeatures: Verwenden Sie Workflow-Variablen und benutzerdefinierte SQL für anspruchsvolle parametrisierte Analysen
Die visuelle Leinwand-Benutzeroberfläche macht komplexe räumliche Analyseautomatisierung für Benutzer aller technischen Ebenen zugänglich und bewahrt dabei die vollständige Dokumentation des analytischen Prozesses für Reproduzierbarkeit und Zusammenarbeit.
1. Benutzeroberflächen-Komponenten
Die Workflow-Benutzeroberfläche besteht aus zwei Hauptpanels und der Workflow-Leinwand und bietet einen intuitiven Arbeitsbereich für die visuelle Workflow-Konstruktion.

Workflow-Management und Projekt-Ebenen Panel
Dieses Panel befindet sich links und ist in zwei Bereiche unterteilt:
Workflow-Management
- Neu: Klicken Sie auf
+ Neuund wählen SieNeu erstellenoderAus Vorlage, um neue analytische Pipelines zu erstellen - Workflow-Liste: Verwalten Sie vorhandene Workflows mit Optionen zum Umbenennen, Duplizieren und Löschen
Projekt-Ebenen
- Ebenenbaum: Schreibgeschützte Anzeige der Datenebenen des Projekts. Sie können sie per Drag-and-Drop auf die Leinwand ziehen, um den Workflow zu erstellen.
- Ebene hinzufügen: Fügen Sie neue Ebenen zum Projekt hinzu, um sie im Workflow- und Kartenmodus zu verwenden.
Workflow-Leinwand
Leinwand-Arbeitsbereich
Der Leinwand-Arbeitsbereich ist der Ort, wo Sie Knoten per Drag-and-Drop bewegen, zoomen, schwenken und Elemente auswählen können. Er enthält mehrere Steuerungsbereiche:

Leinwand-Ansichtsleiste: Befindet sich in der unteren linken Ecke der Leinwand:
Hineinzoomen: Vergrößert die Leinwand-Vergrößerung für detaillierte ArbeitRauszoomen: Verringert die Leinwand-Vergrößerung, um mehr vom Workflow zu sehenAnsicht anpassen: Passt die Ansicht an, um den gesamten Workflow auf einmal anzuzeigenSperren: Verhindert versehentliche Änderungen: Solange die Leinwand gesperrt ist, lassen sich Knoten und Textkarten nicht verschieben, verbinden oder löschen. Schwenken und Zoomen funktionieren weiterhin. MitEntsperrenkönnen Sie wieder bearbeiten
Symbolleisten-Steuerung: Befindet sich am mittleren unteren Rand der Leinwand:
Auswählen: Standard-Cursor zum Auswählen und Bewegen von KnotenTextkarte: Fügen Sie Textanmerkungen hinzu zur Dokumentation von Workflow-SchrittenWiederholen: Stellt die letzte rückgängig gemachte Aktion wieder herRückgängig: Macht die letzte Aktion rückgängigVariablen: Erstellen und verwalten Sie Workflow-Variablen für wiederverwendbare ParameterAusführen: Führt den gesamten Workflow aus
Minimap: Befindet sich in der unteren rechten Ecke der Leinwand und bietet einen Übersichtsnavigator für komplexe Workflows.
Datenansicht-Steuerung: Befindet sich am unteren Rand der Leinwand. Wählen Sie einen Knoten aus, um das Panel zu aktivieren. Es zeigt die Daten des Layers dieses Knotens:
Tabelle: Öffnet die Attributtabelle des ausgewählten KnotensKarte: Öffnet eine Kartenvorschau des Layers des ausgewählten Knotens (nur verfügbar, wenn der Layer Geometrie enthält)
Tastenkürzel
Unter macOS verwenden Sie ⌘ statt Strg.
| Tastenkürzel | Aktion |
|---|---|
Entf oder Rücktaste | Ausgewählten Knoten, ausgewählte Textkarte oder Verbindung löschen |
Strg+Z | Letzte Änderung rückgängig machen |
Strg+Umschalt+Z oder Strg+Y | Zuletzt rückgängig gemachte Änderung wiederholen |
Strg + Klick | Knoten oder Textkarte zur Auswahl hinzufügen |
| Pfeiltasten | Ausgewählten Knoten oder ausgewählte Textkarte verschieben |
Esc | Auswahl aufheben |
Mit der Maus ziehen Sie auf einer leeren Stelle der Leinwand, um sie zu verschieben, und scrollen, um zu zoomen.
- Rückgängig und Wiederholen wirken nicht, während Sie in einem Feld tippen, etwa in einer Textkarte oder einer Werkzeugeinstellung.
- Das Verschieben eines Knotens oder einer Textkarte, per Ziehen oder mit den Pfeiltasten, lässt sich wie jede andere Änderung rückgängig machen.
- Eine Fassung, die über die Leinwand geladen wird, etwa eine Änderung des KI-Assistenten oder die gespeicherte Fassung nach
Neu laden, ist ebenfalls ein Schritt:Strg+Znimmt sie zurück (siehe Einen Workflow mit dem KI-Assistenten ändern). NachNeu ladenholtStrg+ZIhre Fassung zurück, und sie wird dann ohne erneute Nachfrage über die andere Änderung gespeichert. - Solange die Leinwand mit
Sperrengesperrt ist, löschtEntfnichts.
Werkzeuge und Konfigurations-Panel
Das rechte Panel ändert sich je nachdem, ob ein Knoten ausgewählt ist oder nicht. Wenn kein Knoten ausgewählt ist, wird das Werkzeuge und Verlauf Panel sichtbar. Wenn ein Werkzeug-Knoten ausgewählt ist, erscheint das Konfigurations-Panel, und wenn ein Datensatz-Knoten ausgewählt ist, erscheint das Datensatz-Panel.

Werkzeuge und Verlauf Panel
Werkzeuge Tab
Dieser Tab enthält kategorisierte Werkzeuge, die für die Workflow-Konstruktion verfügbar sind, ähnlich der Karten-Modus-Toolbox. Ziehen Sie Werkzeuge per Drag-and-Drop auf die Leinwand, um sie zu Ihrem Workflow hinzuzufügen. Die Werkzeuge sind in die folgenden Kategorien unterteilt:
- Daten I/O
+ Datensatz hinzufügen: Erstellt Datensatz-KnotenDaten abrufen: Ruft OpenStreetMap- oder Overture-Maps-Features aus der Kopie von GOAT ab, bei jeder Ausführung neu. Der Knoten hat keinen Eingang. Beschrieben unten unter Knoten Daten abrufen.Als Datensatz speichern: Speichert Workflow-Ergebnisse als permanente Datensätze. Konfigurieren Sie den Datensatznamen (FeldDatensatzname), aktivieren Sie Zum Projekt hinzufügen, um das Ergebnis automatisch zur Projektlayerliste hinzuzufügen, und aktivieren Sie Bei erneutem Ausführen überschreiben, um das zuvor exportierte Dataset bei jeder Ausführung des Workflows zu ersetzen, anstatt einen neuen Datensatz zu erstellen. Direkt mit einem Datensatz-Knoten verbunden, speichert der Knoten die Features, die dem Filter des Datensatz-Knotens entsprechen, im Stil des Datensatzes.
Vergeben Sie für jeden Als Datensatz speichern-Knoten einen aussagekräftigen Namen und aktivieren Sie Bei erneutem Ausführen überschreiben, wenn Sie denselben Workflow mehrfach ausführen. So bleibt Ihr Projekt übersichtlich und es entstehen keine doppelten Layer nach jeder Ausführung.
Knoten Daten abrufen
Ein Daten abrufen-Knoten braucht keinen Eingangslayer. Er ruft OpenStreetMap- oder Overture-Maps-Features ab und tut das bei jeder Ausführung erneut, sodass das Ergebnis der Quelle folgt.
- Ziehen Sie
Daten abrufenauf die Leinwand und klicken Sie den Knoten an. Das Panel zeigt einen AbschnittQuellemit der SchaltflächeDaten wählen. - Klicken Sie auf
Daten wählen. Es öffnet sich derselbe Dialog wie beiOpenStreetMapundOverture Mapsin Layer hinzufügen: Wählen Sie Layertyp, Gebiet sowie Tag- oder Attributfilter oder SQL. Details finden Sie unter Layer. - Klicken Sie auf
Im Workflow verwenden, um die Auswahl im Knoten zu speichern. Der Knoten übernimmt einen vorgeschlagenen Namen wie „OSM points“. MitBearbeitenöffnen Sie die Auswahl erneut.
Es wird noch nichts abgerufen, daher können die folgenden Knoten schon vor der ersten Ausführung eingerichtet werden. Solange nichts gewählt ist, zeigt der Knoten ein Achtung-Symbol. Es können höchstens 1.000.000 Features abgerufen werden, und sehr große Gebiete werden abgelehnt.
- Erreichbarkeitsindikatoren: Alle Werkzeuge, die im Abschnitt Erreichbarkeitsindikatoren der Toolbox verfügbar sind
- Geoanalyse: Alle Werkzeuge, die im Abschnitt Geoanalyse der Toolbox verfügbar sind
- Geoprozessierung: Alle Werkzeuge, die im Abschnitt Geoprozessierung der Toolbox verfügbar sind
- Datenmanagement
- Verknüpfen, Zusammenführen und andere Datenmanipulations-Werkzeuge
- Benutzerdefiniertes SQL: Erweiterte Datenverarbeitung mit SQL-Abfragen
- Steuerung: Fügen Sie einen
Bedingung-Knoten hinzu, der den Layer basierend auf definierten Bedingungen in einen Wahr- oder Falsch-Pfad weiterleitet. Siehe Bedingung.
Verlauf Tab
Hier können Sie Folgendes sehen:
- Ausführungsprotokoll: Vorherige Workflow-Läufe mit Zeitstempeln und Status
- Ausführungsdetails: Dauer, Erfolg-/Fehlerstatus und Fehlermeldungen
- Ergebniszugriff: Links zu vorherigen Workflow-Ausgaben
Konfigurations-Panel (Werkzeug-Knoten ausgewählt)
Wenn ein Werkzeug-Knoten ausgewählt ist, zeigt das rechte Panel das Werkzeug-Konfigurations-Panel an. Konfigurieren Sie alle werkzeugspezifischen Parameter für die ausgewählte Analyse. Sie können auch Workflow-Variablen in Parameterfeldern für dynamische Werte verwenden.
Datensatz Panel (Datensatz-Knoten ausgewählt)
Wenn ein Datensatz-Knoten ausgewählt ist, erscheint das Datensatz-Panel mit zwei verfügbaren Tabs:
Quelle Tab: Zeigen Sie Metadaten aus der Datenquelle an und greifen Sie auf Tabellen- und Kartenansichten zu. Sie können auch den dem Knoten zugewiesenen Datensatz von diesem Tab aus ändern.
Ein leerer Datensatz-Knoten zeigt Datensatz hinzufügen mit zwei Quellen: Aus Projekt und Meine Datensätze. Sobald ein Datensatz gesetzt ist, wählen Sie mit Datensatz ändern einen anderen.
Filter Tab schon vor der ersten Ausführung eingerichtet werden können. Mit Bearbeiten öffnen Sie die Auswahl erneut.
- Jede Ausführung holt die Daten neu, das Ergebnis folgt also Änderungen in der Quelle.
- Kann die Verbindung nicht ausgeführt werden, zeigt der Knoten ein Hinweis-Symbol mit dem Grund, zum Beispiel wenn eine Ausführung stoppte, weil der WFS nicht erreichbar war.
- Es werden höchstens 1.000.000 Features abgerufen, sehr große Gebiete werden abgelehnt.
Im Workflow verwendenbleibt deaktiviert, bis die Auswahl gültig ist, und nennt den Grund.
Filter Tab: Wenden Sie spezifische Filter für den Workflow an, ohne die ursprüngliche Ebene zu beeinträchtigen.
2. Beispielhafte Anwendungsfälle
- Erreichbarkeitsanalyse-Pipeline: Erstellen Sie Einzugsgebiete, überschneiden Sie mit Bevölkerungsdaten, berechnen Sie Erreichbarkeitsindikatoren und exportieren Sie Ergebnisse
- Standorteignungsbewertung: Puffern Sie Beschränkungen, führen Sie räumliche Überlagerungen durch, wenden Sie Gewichtungsfaktoren an und bewerten Sie geeignete Standorte
- Multi-Source-Datenintegration: Verknüpfen Sie mehrere Datensätze, wenden Sie räumliche Filter an, aggregieren Sie Statistiken und erstellen Sie umfassende analytische Ausgaben
- Qualitätsbewertungs-Workflow: Validieren Sie Datenqualität, prüfen Sie räumliche Beziehungen, generieren Sie Validierungsberichte mit benutzerdefinierter SQL
- Vergleichende Szenarioanalyse: Verwenden Sie Workflow-Variablen, um identische Analysen mit unterschiedlichen Parametern oder Datensätzen durchzuführen
3. Wie man die Workflow-Benutzeroberfläche verwendet
Beginnen Sie mit einfachen 2-3 Knoten-Workflows, um die Benutzeroberfläche zu verstehen, und bauen Sie dann schrittweise komplexere analytische Pipelines auf, wenn Sie sich mit dem System vertraut gemacht haben.
Erstellen Ihres ersten Workflows
Workflows in GOATs Hauptnavigation, um auf die Workflow-Benutzeroberfläche zuzugreifen.+ Neu im linken Panel und wählen Sie Neu erstellen, um mit einer leeren Leinwand zu beginnen, oder Aus Vorlage, um von einem fertigen Workflow zu starten (siehe Mit einer Vorlage starten). Ein neuer Workflow wird mit einem Standardnamen zur Liste hinzugefügt. In einem Projekt ohne Workflows bietet die Leinwand dasselbe in ihrer Mitte an: Neuer Workflow, Mit einer Vorlage beginnen, wenn Ihnen Workflow-Vorlagen zur Verfügung stehen, und den Link Was ist ein Workflow? zu dieser Seite.Weitere Optionen-Menü des Workflows und wählen Sie Umbenennen, um ihm einen Namen zu geben, der Ihr analytisches Ziel widerspiegelt (z.B. „Städtische Erreichbarkeitsanalyse").Erstellen Ihres Workflows
+ Datensatz hinzufügen vom Werkzeuge Tab des rechten Panels auf die Leinwand ziehen oder indem Sie Ebenen direkt vom Projekt-Ebenen Panel links ziehen. Konfigurieren Sie den Datensatz-Knoten so, dass er auf Ihre Eingangsdaten-Ebenen verweist.Ausführung und Verwaltung von Workflows
Ausführen, um den gesamten Workflow von Anfang bis Ende auszuführen. Solange der Workflow Fehler hat, ist die Schaltfläche ausgegraut (siehe Workflows prüfen und ausführen).Tabelle und Karte am unteren Rand der Leinwand, um die Ergebnisse des ausgewählten Knotens zu inspizieren, sobald der Workflow abgeschlossen ist.Workflows speichern Änderungen automatisch, während Sie sie erstellen. Das System bewahrt alle Konfigurationen, Verbindungen und Ausführungszustände auf. Schlägt das Speichern fehl, erscheint oben auf der Leinwand der Hinweis Nicht gespeichert; klicken Sie auf Erneut versuchen, um noch einmal zu speichern.
Wurde der Workflow seit dem Öffnen an anderer Stelle gespeichert, etwa von einer anderen Person oder in einem anderen Tab, ersetzen Ihre Änderungen diese Fassung nicht. Ein Hinweis oben auf der Leinwand zeigt Dieser Workflow wurde an anderer Stelle geändert mit der Angabe, wer ihn wann geändert hat, und bis Sie wählen, wird nichts gespeichert: Klicken Sie auf Neu laden, um die gespeicherte Fassung zu laden, oder auf Meine behalten, um Ihre Fassung darüber zu speichern. Hat der KI-Assistent den Workflow geändert, während Sie ihn bearbeitet haben, lautet der Hinweis Der Assistent hat diesen Workflow geändert, während Sie ihn bearbeitet haben. Schwenken und Zoomen lösen diesen Hinweis nie aus.
Workflows prüfen und ausführen
GOAT prüft den Workflow, während Sie ihn erstellen, und zeigt, was noch Aufmerksamkeit braucht. Nichts davon hindert Sie daran, weiterzubauen oder zu speichern.
- Neben
Ausführenzählt ein Chip wie2 Problemealles, was gefunden wurde. Klicken Sie darauf, um die Liste zu öffnen, gruppiert nach Knoten; Probleme, die den ganzen Workflow betreffen, stehen oben. - Ein Knoten mit einem Problem zeigt unten rechts eine Markierung. Zeigen Sie auf die Markierung oder tippen Sie darauf, um ihre Meldungen zu lesen.
- Ein Eingang, der verbunden sein muss, es aber nicht ist, erhält einen orangefarbenen Ring um seinen Anschluss.
- In den Einstellungen eines Knotens erscheint eine Meldung unter der betroffenen Einstellung, die übrigen Probleme des Knotens stehen oben. Pflichteinstellungen sind mit einem Sternchen (
*) markiert.
Klicken Sie auf ein Problem in der Liste oder an einer Markierung, um dorthin zu gelangen: Die Leinwand springt zum Knoten, wählt ihn aus und öffnet seine Einstellungen bei der betroffenen Einstellung.
| Stufe | Farbe | Bedeutung |
|---|---|---|
| Fehler | orange | Der Workflow kann noch nicht ausgeführt werden, zum Beispiel weil ein Eingang nicht verbunden ist, eine Pflichteinstellung leer ist oder ein Feld im Eingangsdatensatz fehlt. |
| Warnung | grau | Einen Blick wert, verhindert aber nie eine Ausführung, zum Beispiel ein Knoten, der mit keinem anderen Knoten verbunden ist. |
| Ausführungsfehler | rot | Der Knoten ist bei der letzten Ausführung fehlgeschlagen, und seine Markierung zeigt seine eigene Fehlermeldung. Sie verschwindet, sobald Sie den Knoten ändern oder den Workflow erneut ausführen. |
Solange der Workflow Fehler hat, ist Ausführen ausgegraut; zeigen Sie darauf, sehen Sie, wie viele noch offen sind, zum Beispiel Beheben Sie 2 Probleme, um den Workflow auszuführen. Warnungen und Ausführungsfehler deaktivieren Ausführen nie.
Konnte der Workflow nicht geprüft werden, etwa weil die Verbindung unterbrochen war, erscheint ein Chip Nicht geprüft. Klicken Sie darauf, um erneut zu prüfen; ein Lauf wird beim Start immer geprüft.
Kann die gespeicherte Fassung eines Workflows nicht gelesen werden, etwa weil sie außerhalb von GOAT geändert wurde, öffnet er sich mit dem Hinweis Dieser Workflow kann nicht geöffnet werden anstelle der Leinwand, der auflistet, was defekt ist. Ein solcher Workflow kann dort weder bearbeitet noch ausgeführt werden, und GOAT speichert nicht darüber. Die anderen Workflows des Projekts funktionieren weiter.
Mit einer Vorlage starten
Workflows-Panel auf Aus Vorlage, um die Vorlagenübersicht zu öffnen, gefiltert auf Workflow-Vorlagen.Vorlage verwenden.Einen Workflow mit dem KI-Assistenten erstellen
Sie können eine Analyse auch dem KI-Assistenten beschreiben und ihn den Workflow erstellen lassen. Öffnen Sie den Assistenten in einem Projekt, das Sie bearbeiten dürfen, über KI fragen in der oberen Leiste, in der Ansicht Karte oder Workflows, und beschreiben Sie, was Sie brauchen, zum Beispiel Erstelle einen Workflow, der die Gebiete in 15 Minuten Fußweg um die Schulen ermittelt und die Einwohner darin zählt.
- Passt eine Workflow-Vorlage, verwendet der Assistent sie. Andernfalls baut er den Workflow aus den Werkzeugen Ihres Werkzeugkastens, prüft ihn mit derselben Prüfung wie der Editor (siehe Workflows prüfen und ausführen) und behebt, was er kann. Er erstellt den Workflow erst, wenn nur noch offen ist, was Sie wählen: die Layer der offen gelassenen Schritte und die Einstellungen, die diese lesen, etwa ein Feld.
- Müssen Sie wählen, zum Beispiel welcher Datensatz verwendet werden soll, stellt Ihnen der Assistent eine oder mehrere Fragen unten im Assistenten, an der Stelle des Nachrichtenfelds. Mehrere Fragen erscheinen nacheinander: Wählen Sie eine Option (oder mehrere, wo die Frage es zulässt) oder wählen Sie
Eigene Antwort eingebenund geben Sie Ihre Antwort ein; klicken Sie dann aufWeiter.Überprüfenzeigt danach Ihre Antworten, undAntwort sendensendet sie. Bei einer einzelnen Frage stehtAntwort sendendirekt darunter. Die Option, die der Assistent vorschlägt, ist mitEmpfohlenmarkiert und steht an erster Stelle. Um stattdessen im Nachrichtenfeld zu antworten, klicken Sie aufStattdessen als Text antworten. - Der Assistent fügt Ihrem Projekt einen Datensatz aus dem Katalog nur dann hinzu, wenn Sie ihn bei einer solchen Frage als Option wählen, nicht aber, wenn Sie ihn in einer getippten Antwort nennen. Eine Ausnahme ist eine Vorlage: Die Datensätze, die sie mitliefert, kommen mit ihr in Ihr Projekt (siehe Datensätze in einer Vorlage).
- Wenn Sie einen Datensatz offen lassen oder es keine passenden Daten gibt, lässt der Assistent den Datensatz-Knoten leer und benennt den Schritt nach dem, was fehlt. Der Knoten zeigt dann
Kein DatensatzundLayer auswählen, und die Problemliste zeigt unter dem Namen des SchrittsFür diesen Schritt ist kein Datensatz gewählt.an.Ausführenbleibt ausgegraut, bis Sie einen Layer gewählt und ausgefüllt haben, was die Problemliste danach in den Schritten verlangt, die ihn verwenden. - Sind Sie noch in diesem Projekt und hat der geöffnete Workflow keine ungespeicherten Änderungen, öffnet sich der neue Workflow sofort im Editor; andernfalls klicken Sie in der Antwort beim Workflow auf
Öffnen.
Einen Workflow mit dem KI-Assistenten ändern
Sie können den Assistenten auch bitten, einen Workflow des geöffneten Projekts zu ändern, zum Beispiel Setze die Gehzeit auf 10 Minuten und füge eine Notiz hinzu, die das erklärt.
- Der Assistent liest den Workflow zuerst und ändert nur, worum Sie bitten: Schritte, Einstellungen, Verbindungen und Textkarten. Einen Workflow löscht er nie.
- Er prüft den geänderten Workflow mit derselben Prüfung wie der Editor und speichert keine Änderung, die einen Fehler hinzufügt. In seiner Antwort nennt er, was er geändert hat.
- Ist der Workflow im Editor geöffnet, zeigt die Leinwand die Änderung sofort.
Strg+Z(unter macOS⌘+Z) auf der Leinwand nimmt die Änderung in einem Schritt zurück. - Unter einer Antwort, die einen Workflow geändert hat, steht
Rückgängig; bei älteren Antworten zeigen Sie auf die Antwort, um es zu sehen. Ein Klick nimmt alle Änderungen dieser Antwort zurück, auch wenn der Workflow nicht geöffnet ist. Die Schaltfläche lautet danachRückgängig gemacht. - Wurde der Workflow nach der Antwort erneut gespeichert, fragt
Rückgängigzuerst nach und nennt, wer ihn wann geändert hat.Trotzdem rückgängig machennimmt auch diese späteren Änderungen zurück. Hat der Editor Änderungen, die noch nicht gespeichert sind, fragtRückgängigebenfalls; nachTrotzdem rückgängig machenwählen Sie im Hinweis oben auf der Leinwand, welche Fassung bleibt.
Einen Workflow mit dem KI-Assistenten ausführen
- Fragen Sie nach einem Ergebnis, zum Beispiel Wie viele Einwohner wohnen höchstens 15 Minuten Fußweg von einer Schule entfernt?, erstellt der Assistent den Workflow und führt ihn aus. Einen Workflow, den er in dieser Unterhaltung erstellt hat, führt er ohne Rückfrage aus. Jeden anderen, etwa einen, den Sie selbst erstellt haben, führt er erst aus, wenn Sie zustimmen: Der Assistent fragt Sie in einer Karte, ob er ihn ausführen soll, und nichts läuft, bevor Sie sich dafür entscheiden.
- Während der Workflow läuft, zeigt die Antwort eine Zeile wie
Workflow läuft: Schritt 2 von 4, Einzugsgebietmit der Zeit seit dem Start.In Workflows öffnenöffnet den Workflow, wo die Leinwand den Lauf zeigt. Zeigt die Antwort die Karte des Workflows, öffnen Sie ihn stattdessen mitÖffnenauf der Karte. - Der Assistent wartet auf den Lauf und berichtet das Ergebnis in seiner Antwort, mit den Layern, die der Lauf gespeichert hat. Ist der Lauf fehlgeschlagen (
Workflow-Lauf fehlgeschlagen), nennt er den Schritt, der fehlgeschlagen ist, und was zu ändern ist. - Dauert der Lauf länger, als die Antwort warten kann, lautet die Zeile
Der Workflow lief noch, als diese Antwort endete. Der Lauf geht weiter; fragen Sie den Assistenten später nach dem Ergebnis. Stoppen Sie die Antwort, stoppt auch ein Lauf, den sie gestartet hat.
Einen Workflow als Vorlage speichern
Sobald ein Workflow eingerichtet ist, können Sie ihn als Vorlage speichern, damit er ohne erneute Einrichtung mit anderen Daten oder von anderen Personen wiederverwendet werden kann.
Weitere Optionen-Menü des Workflows und wählen Sie Als Vorlage speichern….Namen und optional eine Beschreibung sowie Kategorien.Speicherort (einen Bereich und Ordner), an dem die Vorlage gespeichert wird. Alle, die diesen Ordner öffnen können, können die Vorlage verwenden.Eingaben-Tabelle für jeden Eingabe-Layer, ob er mit der Vorlage mitgeliefert wird oder die Vorlage bei der Verwendung nach einem Layer fragt. Ein mitgelieferter Layer wird zusammen mit der Vorlage geteilt, damit andere sie ausführen können. Für einen mitgelieferten Layer können Sie auch Kopie für jeden Nutzer (mit Inhalt) oder Leere Kopie für jeden Nutzer wählen, damit alle eine eigene bearbeitbare Kopie statt Ihres schreibgeschützten Layers erhalten (siehe Datensätze in einer Vorlage).Speichern.Wenn Sie einen Export-Knoten ausgeführt und seinen Ergebnis-Layer gestylt haben, übernimmt die Vorlage dieses Styling. Wer die Vorlage nutzt, sieht Ihr Styling schon beim ersten Ausführen. Ein Export, der ein früheres Ergebnis überschreibt, behält das Styling dieses Layers.
Wenn aus diesem Workflow bereits eine Vorlage gespeichert wurde, können Sie sie aus der Quelle aktualisieren mit der aktuellen Version, anstatt ein Duplikat zu erstellen. Da die Eingaben Teil des gespeicherten Snapshots sind, verwenden Sie Vorlage aus Quelle aktualisieren, um sie zu ändern.
4. Workflows aus der Kartenansicht ausführen
Workflows können auch direkt aus der Kartenansicht ausgeführt werden, ohne den Workflow-Editor zu öffnen. Öffnen Sie die Toolbox, klicken Sie auf den Tab Workflows und wählen Sie einen Workflow aus der Liste. Wenn der Workflow Variablen enthält, erscheint ein Abschnitt Variablen, in dem Sie Werte vor der Ausführung festlegen können.